
Thème 02 - Les outils de base 1 

La fenêtre ImageJ se compose de trois parties. Une barre de menus, une barre d'outils et une barre 
d'état. Vous allez maintenant apprendre à connaître les outils de base d'ImageJ plus en détail.

 
Excercise 2.1: informations Pixel, zoom et le défilement 

Ouvrez l'image A4 dapi 1.tif à partir du dossier 01 – opening images.
- Notez que certaines informations sur l'image sont affichées en haut de la fenêtre image. La taille 
de l'image en pixel, le type et la taille de l'image dans la mémoire de l'ordinateur. 
- Sélectionnez l'outil loupe sur la barre d'outils et cliquez sur l'image. Un clic gauche fait un zoom-
in, un clic droit sur un zoom-out. Vous pouvez utiliser les touches "+" et "-" du clavier pour faire un 
zoom. 
- Notez l'indicateur de position dans le coin supérieur gauche, lorsque l'image est plus grande que la 
fenêtre. 
- Zoom-in afin que l'indicateur de position apparaisse. Sélectionnez l'outil de défilement (la main) 
sur la barre d'outils. Cliquez sur l'image et sans relâcher le bouton Déplacer la souris. Allez dans le 
coin inférieur droit de l'image. 
- Sélectionnez l'outil loupe de nouveau. Zoom-in afin que l'indicateur de position apparaisse. Vous 
pouvez faire glisser l'image en appuyant sur la barre d'espace au lieu d'utiliser l'outil défilement. 
L'avantage est que d'un autre outil peut être actif en même temps. Essayez de faire défiler vers le 
coin inférieur gauche. 
- Zoom in au maximum et déplacez la souris sur l'image. Regardez la barre d'état de la fenêtre 
ImageJ. La position du pixel situé sous le pointeur de la souris et sa valeur en niveaux de gris sont 
affichées. 
a) Quel est le maximum possible de zoom? 
Quel est le minimum de zoom? 
b) Quel est la valeur en niveaux de gris du pixel 
de coordonnées x = 549 et y = 305? 
et  du pixel de coordonnées x = 58 et y = 246? 
c) Quelle est la largeur et la hauteur de l'image?
 Quel est son type?
Quelle est sa taille dans la mémoire? 
d) Déplacez la souris sur l'image. Dans quelle 
direction les coordonnées x augmentent ? 
Dans quelle direction les coordonnées y 
augmentent?
A quoi ressemble le système de coordonnées? 



 
 
e) Vous pouvez changer l'orientation de l'axe des y. Ouvrir la boîte de dialogue Analyse> Set  
Measurements ... et sélectionnez Invert Y coordinates. Déplacez la souris sur l'image à nouveau. 
Comment le système de coordonnées a changer? Désélectionnez Invert Y coordinates.

Exercice 2.2: outils de sélection Zone 

Assurez-vous que l'outil de sélection rectangulaire est actif. Vous pouvez maintenant faire une 
sélection rectangulaire dans l'image en cliquant sur un point et en faisant glisser la souris. Tout en 
faisant cela la largeur, la hauteur et le ratio de la sélection sont affichés. Lorsque vous relâchez le 
bouton de la souris que vous avez fait une sélection sur l'image. Vous pouvez toujours modifier sa 
position en cliquant à l'intérieur de la sélection et en la faisant glisser. En utilisant les poignées vous 
pouvez modifier la taille de la sélection. 
a) Faire une sélection rectangulaire sur l'image, déplacer la, modifier sa taille. Trouver dans la 
documentation ImageJ (ImageJ User Guide) quelles sont les touches de modification pour l'outil de 
sélection rectangulaire et ce qu'elles font. Essayez-les. 
b) Notez que vous pouvez réaliser des sélections complexes en utilisant les touches  Maj ou Alt. 
Maj ajoute à une sélection. Alt supprime d'une sélection. Essayez-les. Déplacer la sélection 
complexes . Notez que vous créez une seule sélection, même si les parties peuvent être séparés. 
c) Modifier la couleur de sélection en magenta (Edit>Options>Colors...). 
d) Clic-droit sur l'outil de sélection rectangulaire, et sélectionnez l'outil  rectangle arrondi. Faites 
une sélection. Notez que, contrairement à l'outil rectangle, cet outil utilise la couleur de premier 
plan. Vous pouvez la modifier en double-cliquant sur l'outil Color-picker. Il utilise aussi la largeur 
de ligne courante. Changez-la dans Edit>Option>Line Width
e) Double-cliquez sur l'outil  rectangle arrondi. Une boîte de dialogue s'ouvre. Modifiez la valeur de 
l'option « Corner diameter » et  tracer une nouvelle sélection. 
f) Essayez les autres outils de sélection d'aire jusqu'à l'outil à main levée. Notez que lorsque vous 
utilisez l'outil de sélection à main levée, vous ne devez pas essayer de fermer vous-même. Il suffit 
d'aller à proximité de début et relâchez le bouton de la souris. La sélection sera automatiquement 
fermée. 
g) Faites une sélection et exécutez la commande Image>Crop. Qu'est-ce qu'il se passe? 

Vous pouvez recharger l'image originale du disque en utilisant File>Revert (ctrl+r). Faites une 
nouvelle sélection  et exécutez la commande Image>Duplicate (shift+d). Qu'est-ce qu'il se passe? 



Exercice 2.3: Mesure et le tableau des résultats 

La commande Analyze>Measure (m) mesure les propriétés de l'image entière ou de la sélection s'il 
en existe une. Avec la boîte de dialogue Analyze>Set Measurements vous pouvez choisir les 
propriétés qui seront mesurées. Les mesures sont inscrites dans le tableau global des résultats. 

a) Utiliser l'outil freehand-selection pour sélectionner un noyau, puis mesurer sa surface et sa valeur 
moyenne en niveaux de gris. Faites la même chose pour plusieurs noyaux. Zoomer sur l'image pour 
faire une sélection précise. {polygone selections, edit-selection-fit spline}
b)Dupliquer la fenêtre Results File>Duplicate. Revenir à l'image pour faire une nouvelle mesure. 
Dans quelle fenêtre de résultat est-elle ajoutée? 

c) Utilisez la commande File>Rename pour renommez la table de résultats d'origine (Results) en 
«Results_old». Faire une nouvelle mesure. Dans quel tableau des résultats est-elle ajoutée? 

d) Effacer le tableau des résultats en utilisant Results>Clear Results et mesurer au moins 3 
noyaux de nouveau. Quelle est la moyenne, l'écart-type, le min, le max et la distribution des 
surfaces? Utiliser Results>Summarize et Results>Distribution... pour obtenir les réponses.

Exercice 2.4: outils de sélection de ligne 

Essayez les outils de sélection ligne straight, segmented, freehands. 
Notez que lors de la création d'une ligne droite ou d'une ligne segmentée,  la longueur du segment 
en cours et l'angle avec l'axe des x sont affichés dans la barre d'état. 
a) Utilisez l'outil straight-line pour mesurer les distances entre les centres des noyaux. 
b) Utilisez l'outil straight-line pour mesurer le diamètre des noyaux. 
c) Utilisez l'outil segmented-line pour mesurer les périmètres des noyaux. 
d) Utilisez l'outil freehand-line pour mesurer les périmètres des noyaux. 
e) Utilisez l'outil angle tool pour mesurer l'angle entre trois noyaux. 



Exercice 2.5: Profil d'intensité 

Vous pouvez utiliser les outils de sélection de ligne pour créer un profil d'intensité « plot profile » : 
c'est la courbe des valeurs d'intensité le long de la ligne. 
Faire d'abord une sélection de ligne à travers un noyau, puis appuyez sur la touche k (le raccourci 
pour Analyze->Plot profile). Notez que, lorsque la largeur de la ligne est >1, le profil sera la 
moyenne sur la largeur de la ligne. Vous pouvez modifier la largeur de ligne en double-cliquant sur 
le bouton de l'outil ligne. 

a) Utiliser un profil d'intensité pour estimer le diamètre d'un noyau. Notez que le profil d'intensité 
est aussi une image sur laquelle vous pouvez utiliser les outils d'ImageJ . Y a t-il un avantage à 
utiliser un profil d'intensité plutôt que de mesurer le diamètre de l'image originale? 

b) Créer un profil d'intensité dans un noyau. Sans changer la sélection, modifiez la largeur de la 
ligne et créer un nouveau profil d'intensité. Y at-il des changements? 

c) Créer un profil d'intensité à travers un noyau, agrandir la ligne et créer un autre profil d'intensité 
(La meilleure façon de le faire sans changer la direction est d'utiliser une ligne horizontale ou 
verticale avec shift enfoncée.). Quelle est la différence entre les profils d'intensité? Mesurer les 
distances entre les deux mêmes points intéressants dans les deux profils d'intensité. Pensiez-vous 
obtenir le même résultat dans les deux profils d'intensité? Comment est-ce possible? - Indice: 
Regardez la largeur en pixels et la hauteur dans les propriétés des deux images 
(Image>Properties...). 

d) Créer un profil d'intensité dans un noyau. Cliquez sur le bouton List dans la fenêtre du profil. 
Copier les valeurs dans le presse-papiers (Ctrl + A pour les sélectionner toutes et ctrl + C pour 
copier). Ouvrez  Analyze>Tools>Curve Fitting... Supprimer les valeurs initiales et coller les valeurs 
du profil (Ctrl + v). Utiliser une gaussienne pour tracer la courbe des points de mesure. 



Exercice 2.6: sélections Point 

Vous pouvez utiliser les outils de sélection « point » pour compter manuellement des objets dans 
une image. Vous pouvez utiliser l'outil Point et ajouter des points avec la touche shift enfoncée ou 
l'outil Multipoint. Vous pouvez supprimer des points en utilisant la touche alt. 
Règler les options de l'outil point (double clic dessus le bouton) en ne cochant que Label Point 

a) Faire une sélection de 3 points sur trois noyaux, puis faire un point quelque part dans l'arrière-
plan et ajouter des points sur les noyaux restants. Supprimer le point sur le fond en utilisant alt-clic. 
Qu'advient-il de la numérotation des points? 

b) Enregistrer une image avec une sélection de point quelque part au format TIF 
(File>Save As>Tiff...). Fermer l'image et de recharger l'image enregistrée (File>Open...). Qu'est-il 
arrivé à la sélection? Peut-on encore le modifier? 

c) Vérifier l'option Auto-Mesure de l'outil Point. Que fait-il? Astuce: Regardez le tableau des 
résultats. 

d) Utiliser l'outil de sélection de point avec les options Auto-Mesure  et  Auto-Next Slice pour 
pointer la particule jaune dans l'image moving-particles.tif  du dossier 02 - basic tools

Exercice 2.7: seuillage et baguette magique 

La baguette magique permet de faire une sélection de pixels connexes dans une image. Il y a deux 
façons de déterminer quels sont ces pixels. Soit l'outil sélectionne tous les pixels avec la même 
valeur intensité (éventuellement plus ou moins une tolérance donnée) ou elle sélectionne tous les 
pixels ayant une intensité plus grande qu'un minimum donné. Le seuil peut être réglé en utilisant la 
fenêtre de seuillage Image>Adjust>Threshold (shift+t). 
Changer l'option d'affichage de Red à Over/Under 
Chaque clic avec l'outil baguette sur une zone seuillée crée une sélection. Si vous voulez supprimer 



la sélection ctrl + shift + a. 

Ouvrez l'image A4 dapi 1.tif à partir du dossier 01 – opening images.

a)  Utiliser l'outil baguette en combinaison avec le réglage de seuil pour sélectionner les noyaux. 
Mesurer les noyaux.
Quels sont les valeurs du plus petit et du plus grand 
périmètre?
Quels sont les valeurs du plus petit et du plus grand 
diamètre? 
  

b) Utilisez l'outil baguette pour sélectionner tous les noyaux dans une seule sélection (shift-clic). 
Pour  savoir quel pourcentage de l'image est couvert par les noyaux. Astuce: Vous pouvez utiliser la 
commande Edit>Selection>Make Inverse pour inverser une sélection. 

Exercice 2.8: Le roi-manager 

Le roi-manager est un outil qui permet de travailler avec les sélections. Vous pouvez conserver un 
nombre illimité de sélections, afficher, les modifier et de les mesurer quand vous le voulez. Dans la 
fenêtre du ROI-manager  les commandes agissent sur la ROI sélectionnée ou sur toutes les ROI  si 
aucune n'est sélectionnée. 
Sur l'image A4 dapi 1.tif 
a) Utiliser l'outil baguette pour sélectionner un noyau, puis appuyer sur la touche 't' (raccourci pour 
ajouter au roi-manager Analyze>Tools>ROI Manager...). Sélectionnez l'option Show All sur le roi-
manager. Sélectionnez les autres noyaux ajouter les au roi-manager. 

b) Cliquez dans l'image sur un label (par exemple 5). Notez que la ligne correspondante dans le roi-
manager est sélectionnée. Modifier la sélection (enlever une partie en utilisant l'outil Freehand lines 
avec alt enfoncée). Appuyez sur le bouton Update  du roi-manager pour rendre le changement 
permanent. 

c) Sélectionnez une ou plusieurs lignes dans le roi-manager (vous pouvez utiliser Ctrl / shift) et 
appuyez sur le bouton Measure. Appuyez sur le bouton Deselect, fermer la fenêtreles résultats et 
appuyez à nouveau sur Measure. 

d) Qu'est-ce que fait Flatten? Astuce :Regarder sur le type d'image résultante. 

e) Définir le seuil inférieur de sorte que l'arrière-plan soit bleu et qu'il n'y ai pas de trous dans les 
noyaux. Vous pouvez créer une sélection à partir des valeurs de seuillage en utilisant 
Edit>Selection>Create Selection. Ajouter la sélection dans le roi-manager .Exécutez la commande 
Split du roi-manager. Qu'est-ce qu'il se passe? 



f) Ajouter les sélections de tout les noyaux dans le roi-manager. Maintenant, ouvrez l'image 
A4 Rhod 1.tif  à partir du dossier 02 - basic tools. Avec l'image nouvellement chargée, désactivez 
l'option Show All dans le roi-manager et le sélectionner la à nouveau. Appuyez sur Measure. Qu'est-
ce qu'il se passe? 

Exercice 2.9: Mesure d'objets avec l'analyseur de particules 

Jusqu'à présent, toutes les sélections ont été créées individuellement. Le particule-analyseur permet 
de créer automatiquement une sélection pour chaque objet (particules) : une région de pixels ayant 
une valeur comprise entre le seuil minimum et le seuil maximum. 
Sur l'image A4 dapi 1.tif 

a) Utiliser le seuillage (Image>Adjust>Threshold ou shift+t) et le particule-analyseur 
(Analyse>Analyse Particles...) afin d'ajouter les noyaux au roi-manager (tout dé-sélectionner dans 
la boite de dialogue du particule-analyseur sauf Add to Manager). 

b) Supprimer tout dans le roi-manager et utiliser de nouveau le particule-analyseur. Cette fois, 
sélectionnez l'option Exclude on edges. Pouvez-vous expliquer ce que fait cette option et quand elle 
doit être utilisée? 

c) Utiliser le particule-analyseur de nouveau. Cette fois, essayez d'exclure les objets qui sont trop 
petits pour être des noyaux en fixant une taille minimale dans la boîte de dialogue.

d) Utiliser le particule-analyseur pour sélectionner seulement les noyaux qui ont une valeur faible 
de circularité. Quel est la valeur qui exclut les deux noyaux ayant la valeur de circularité la plus 
faible? 



e) Ouvrez l'image inclusion.tif.. Imaginez que les rectangles blancs sont des objets. Utilisez le 
particule-analyseur avec et sans l'option Include holes. Quelle est la différence? 

f) Utiliser le particule-analyseur pour savoir combien de taches lumineuses il y a dans l'image 
blobs.gif dans le dossier 02 - basic tools. Quelle est la superficie moyenne des taches? 

Exercice 2.10: Les flèches, des annotations et des superpositions 

Les images peuvent être annotées de manière non destructive, en utilisant des 
superpositions « overlays ». Les flèches et d'autres sélections peuvent être ajoutées à l'overlay  en 
appuyant sur la touche 'b' (Image>Overlay>Add Selection). 
Sur l'image A4 dapi 1.tif 
a) Utiliser l'outil flèche (clic-droit sur le bouton line) pour créer les flèches qui pointent vers les 
noyaux. Avant de créer les flèches, utilisez les options de l'outil flèche pour définir la couleur 
magenta.
b) Utilisez l'outil de texte pour écrire une annotation pour chaque flèche (noyau1, noyau2) . 
Appuyez sur ctrl + alt + b pour ajouter du texte à l'overlay 
c) Modifier les flèches. Astuce: Utilisez Image>Overlay>To ROI Manager. N'oubliez pas de 
cliquer sur le bouton Update du roi-manager après la modification d'une flèche. 
d) Remplacer le texte du noyau1 par un autre texte (« le premier noyau »). Astuce: - Vous ne pouvez 
pas modifier le texte lui-même. Sélectionnez le texte dans le roi-manager, écrire un nouveau texte 
avec l'outil texte et appuyez sur le bouton Update. 
e) Ajouter une troisième annotation. Astuce: Convertir la sélection de nouveau en overlay, ajouter la 
nouvelle annotation à l'overlay. 
f) Utiliser Flatten pour créer une image contenant les annotations que vous pouvez copier dans 
votre présentation. Dans cette image les annotations ne sont pas superposées à l'image, les valeurs 
des pixels ont été changées. 
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